terça-feira, 19 de janeiro de 2016

Poderoso CALC - Qual nome repete mais?

Saber a quantidade de vezes que um nome aparece na lista e exibir o nome que mais vezes aparece numa lista no Calc do Libreoffice.

Usando as Funções SOMASE(), MAIOR() e PROCV() elaborei  o arquivo o qual anexo a este artigo. Pode ser a solução de um problema assim. Antes vamos mostrar como o arquivo foi construído.

FUNÇÃO =SOMASE($B$1:$B$8;B1;$C$1:$C$8) Arraste esta fórmula para baixo, quantas linhas precisar. Obs: o símbolo dólar na fórmula é para manter a mesma fórmula ao arrastar  para baixo. Já a célula B1, vai mudando o endereço das linhas ficando B2, B3, B4... conforme vai se copiando a fórmula para baixo.

Aqui, pode-se ainda substituir a função SOMASE() pela CONT.SE,() economizando uma coluna.

=SOMASE(B1:B8;B1;C1:C8) Note que na Célula A1 fica a função SOMASE() e que nas células B1 ao B8 estão os nomes (interválo a ser analisado), na Célula B1 está o nome (critério) e ainda que na célula C1 (valor a ser somado de acordo com o critério) está o valor 1 a ser somado.



















 Insira a Função maior onde quer que saia o número (quantidade) do total de vezes repetidas.. 














Coloque a função abaixo na primeira coluna do lado direito, onde foi aplicada a Função maior e sairá o nome que teve X vezes repetido.


Nenhum comentário:

Postar um comentário